Прочитайте, как обстоят дела у сайта Дневников и как вы можете помочь!
×
12:56 

кракозябрик
сабж со стажем
/usr/bin/ld: cannot find -lftdi1

не могу установить вот это spritesmods.com/?art=ftdinand&page=3

установил libusb 1.0 : sudo apt-get install libusb-devlibusb 1.0
установил libconfuse : sudo apt-get install libconfuse-dev
установил libftd: sudo apt-get install libftdi-dev
скачал софт spritesmods.com/ftdinand/ftdinandreader.tgz вот отсюда spritesmods.com/?art=ftdinand&page=4
распаковал
пишу make
он мне пишет

g++ -o ftdinandreader -L/usr/local/lib/ -lftdi1 main.o FtdiNand.o NandChip.o NandID.o NandData.o NandDataSP.o NandDataLP.o
/usr/bin/ld: cannot find -lftdi1
collect2: error: ld returned 1 exit status
Makefile:6: recipe for target 'ftdinandreader' failed
make: *** [ftdinandreader] Error 1

я нифига не программист
я не понимаю что ему надо
помогите плз

Комментарии
2017-09-23 в 16:02 

fire-dragon
не хватает библиотеки
www.intra2net.com/en/developer/libftdi/

вводишь в консоли

apt-cache search ftdi
эта команда ищет пакеты с этим словом, возможно что тебе нужен пакет flashrom ftdi-eeprom

если нет то делаешь поиск в системе где libftdi1.so

и вызываешь скрипт ./configure --help
./configure - тут пишешь дополнительные опции
например

./configure --with-lftdi=/usr/lib
make

2017-09-23 в 16:14 

fire-dragon
все еще проще, правишь файл Makefile
OBJS=main.o FtdiNand.o NandChip.o NandID.o NandData.o NandDataSP.o NandDataLP.o
CXXFLAGS=-ggdb
LDFLAGS=-L/usr/local/lib/ -lftdi
TARGET=ftdinandreader
$(TARGET): $(OBJS)
$(CXX) -o $@ $(LDFLAGS) $(OBJS)

clean:
rm -f $(TARGET) $(OBJS)

2017-09-23 в 17:30 

кракозябрик
сабж со стажем
спасибо *_*

Комментирование для вас недоступно.
Для того, чтобы получить возможность комментировать, авторизуйтесь:
 
РегистрацияЗабыли пароль?

Помощь @экспертов – Хард и софт

главная